Getting code P1643

Hummer H1 and Military Humvee topics
Post Reply
butchh
Posts: 11
Joined: Thu 05 Feb , 2009 10:36 am

Getting code P1643

Post by butchh » Sun 30 Sep , 2012 9:12 am

Check engine light is on and code P1643 is up. I have checked everything per the manual and can not find a problem. I have a 1996 H1 TD,wagon, bought used a couple years ago. Is this a problem of this year H1?? Does it effect the feed back to the PCM on how the H1 runs. Also does anyone know if there is a way to tell which year PCM you have?? Any thought would be appreicated. Thanks Butchh

User avatar
h1sp
Posts: 2038
Joined: Fri 09 Feb , 2007 1:39 pm
Location: TEXAS

Re: Getting code P1643

Post by h1sp » Tue 02 Oct , 2012 11:43 am

6.5L fault Code P1643 Wait to Start Lamp Control Circuit ?

Have you had any Glow Plug relay system, Glow Plug controller, Anyone installed a bypass or a new computer on your rig?

im almost sure the Glow plug light is computer controlled in your truck. its flipped on and off by a relay.

Im lost after any after market equipment is installed. (computer, glow plug by pass stuff)

Im a read a code, find the bad part, plug, play and drive away type guy.

page 2-8 in your manual will have the chart your looking for. "check your fuse"

Maybe someone else can chime in and help
2000 HMC4
"Candy Apple RED"
Stock with Run Flats
1 of 57

butchh
Posts: 11
Joined: Thu 05 Feb , 2009 10:36 am

Re: Getting code P1643

Post by butchh » Tue 02 Oct , 2012 5:32 pm

Thanks for the input. It is nice to talk to someone who has a H1. I do not think that there are any after market things done to the H1. I dont do things that change the orginial, I to am a plug and go also. I have checked everthing that the manual said to check. (fuse included) In my case I am not sure if anything was done before I got it. That is why I was asking if anyone new how to tell which year PCM one had. It starts right away, turn the key after the wait light and it is running, no problem there. I just dont like the check engine light on, and the code P1643. I also dont know if it is sending other information back to the PCM.


Thanks for your thoughts and nice to talk with you. How is the weather in Texas, I am in Oregon.

User avatar
h1sp
Posts: 2038
Joined: Fri 09 Feb , 2007 1:39 pm
Location: TEXAS

Re: Getting code P1643

Post by h1sp » Wed 03 Oct , 2012 6:41 am

butchh wrote:Thanks for the input. It is nice to talk to someone who has a H1. I do not think that there are any after market things done to the H1. I dont do things that change the orginial, I to am a plug and go also. I have checked everthing that the manual said to check. (fuse included) In my case I am not sure if anything was done before I got it. That is why I was asking if anyone new how to tell which year PCM one had. It starts right away, turn the key after the wait light and it is running, no problem there. I just dont like the check engine light on, and the code P1643. I also dont know if it is sending other information back to the PCM.


* im almost sure it does not send the infor back from the PCM, i think the PCM sends the code and its done. I think its generated by a solenoid switch (but now im over my plug and play tech head) If you know anyone with a H1, ask if you can swap the PCM for 30 minutes.

The weather is turning nice now. Im ready for the Holidays.

Thanks for your thoughts and nice to talk with you. How is the weather in Texas, I am in Oregon.
2000 HMC4
"Candy Apple RED"
Stock with Run Flats
1 of 57

Post Reply